It is currently 05 Aug 2021, 16:50

All times are UTC [ DST ]


Search found 3 matches

Author Message

 Jump to forum   Jump to topic

Posted: 11 Dec 2020, 15:07 

I think the black piece should be attached to the metal rod behind the optical unit, to the right side as we see it in the picture. It is probably meant to block the optical unit from travelling too far back and it helps support the metal rod from not moving. I guess that the copper colored screw is there to block the metal rod from lifting itself out. Check the black piece and look for a rectangular hole in the plastic where the screw sits. It may be this part and I think it will be replaceable if you get the part number.

 Jump to forum   Jump to topic

Posted: 11 Dec 2020, 15:19 

I think the black piece should be attached to the metal rod behind the optical unit, to the right side as we see it in the picture. It is probably meant to block the optical unit from travelling too far back and it helps support the metal rod from not moving. I guess that the copper colored screw is there to block the metal rod from lifting itself out. Check the black piece and look for a rectangular hole in the plastic where the screw sits. It may be this part and I think it will be replaceable if you get the part number.

I guess I already see a broken connection in the ribbon cable for the optical unit. Far left on the angled ribbon cable you can see a cut-out, probably caused by the black piece floating around in there and scraping everything it touches. These ribbon cables are fragile and easily damaged. This may cause trouble for the laser optical unit and also explain why it won't work. :thumbdown:

 Jump to forum   Jump to topic

Posted: 11 Dec 2020, 17:43 

I'm no tech but I see that back corner smashed in, I would start with fixing the case to make sure its not going to press on anything or make
sure you don't see any broken boards or parts.

Laserpaal sees some issue with the cable, I would try to figure out what else may be issue like that.
Good luck, sorry the player came damaged, its a shame when you get these players damaged and worked fine before being sent.

My first player from the mail was damaged and I had to get it repaired back in 2004
Page 1 of 1 [ Search found 3 matches ]


All times are UTC [ DST ]


Jump to: