LaserDisc Database
https://forum.lddb.com/

Kenwood LVD-290 fuse/ARC suppressor advice
https://forum.lddb.com/viewtopic.php?f=30&t=9863
Page 1 of 1

Author:  rubenerd [ 13 Jun 2021, 11:42 ]
Post subject:  Kenwood LVD-290 fuse/ARC suppressor advice

Long time reader, first time poster, etc!

I've inherited my old man's Kenwood LVD-290 from Singapore. This is the only mention of it I've ever been able to find, it's definitely a bit of an odd ball. AC-3 and made for the European market, but it's NTSC.

It worked perfectly the first time I used it, but the second time it refuses to power on. The fuse on the power supply was blown, but I replaced twice more with identical ones and they blew again.

I've been doing a bunch of reading, and the most common suggestion I read is that it could be a shorted ARC suppressor. I only know enough to be dangerous, so I'm not sure if the power supply has one, or which component it'd be. Anyone have any ideas where I should start?

Attachment:
psu-front.jpg
psu-front.jpg [ 337.69 KiB | Viewed 253 times ]


Attachment:
psu-back.jpg
psu-back.jpg [ 471.88 KiB | Viewed 253 times ]

Author:  cplusplus [ 16 Jun 2021, 19:19 ]
Post subject:  Re: Kenwood LVD-290 fuse/ARC suppressor advice

I don't see any arc suppression in your photos. In the LD realm this is a late-model Pioneer issue.

Start with checking everything that begins with F for continuity and IC/ICP (or anything that looks like a two leg transistor- maybe IC221).

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/