It is currently 20 Jun 2021, 11:41




 Page 1 of 1 [ 6 posts ] 
Author Message
 Post subject: [LD-660] Video output works great but absolutely no sound
PostPosted: 12 May 2021, 03:53 
Third post and above
Third post and above
User avatar

Joined: 12 May 2021, 03:45
Posts: 3
Location: United States
Has thanked: 0 time
Been thanked: 0 time
Hello everyone,
I've just purchesed the player mentioned above, its my first, and I've actually created this account to ask this question. I consider myself fairly handy, so far I've fiddled with the buttons, messed with connections, and I even opened it up and checked fuses for continuity. I'm really stumped here. Thanks.
Offline
 Profile  
 
 Post subject: Re: LD-660 Video output works great but absolutely no sound
PostPosted: 12 May 2021, 06:16 
Advanced fan
Advanced fan
User avatar

Joined: 28 Jun 2014, 05:59
Posts: 871
Location: San Francisco, CA USA
Has thanked: 147 times
Been thanked: 247 times
Can you tell us more about how you hooked it up to your TV? Also, how does the picture quality look? Is really clear or do you get any distortion?
Offline
 Profile  
 
 Post subject: Re: LD-660 Video output works great but absolutely no sound
PostPosted: 12 May 2021, 12:16 
Third post and above
Third post and above
User avatar

Joined: 12 May 2021, 03:45
Posts: 3
Location: United States
Has thanked: 0 time
Been thanked: 0 time
ldfan wrote:
Can you tell us more about how you hooked it up to your TV? Also, how does the picture quality look? Is really clear or do you get any distortion?

I think the picture is fairly clear like I said its my first player and its quite an old one so I can't be totally sure. I have it hooked up with coax from Vhf out, no sound, so then I tried plugging rca cables from my stereo and still nothing.
Offline
 Profile  
 
 Post subject: Re: [LD-660] Video output works great but absolutely no soun
PostPosted: 12 May 2021, 18:57 
Advanced fan
Advanced fan
User avatar

Joined: 28 Jun 2014, 05:59
Posts: 871
Location: San Francisco, CA USA
Has thanked: 147 times
Been thanked: 247 times
Sounds to me that there is definitely something wrong with the audio stage of the player. Could easily be cold solder or even worn capacitors. This is an analog audio only machine since it is a 1st gen player.

If you try and turn up the volume, can you hear even a tinny amount of sound?

It’s surprising that it can even play the disc since most of these helium neon laser players usually have bit the dust by now. If you try to open it, take extreme caution as these players have a lot of high voltage compared to later players.
Offline
 Profile  
 
 Post subject: Re: [LD-660] Video output works great but absolutely no soun
PostPosted: 12 May 2021, 19:31 
Third post and above
Third post and above
User avatar

Joined: 12 May 2021, 03:45
Posts: 3
Location: United States
Has thanked: 0 time
Been thanked: 0 time
ldfan wrote:
:problem: If you try and turn up the volume, can you hear even a tinny amount of sound?

I can hear something but it doesnt seem related to the disc playing just static. Any ideas on what I should do?
Offline
 Profile  
 
 Post subject: Re: [LD-660] Video output works great but absolutely no soun
PostPosted: 13 May 2021, 00:40 
Advanced fan
Advanced fan
User avatar

Joined: 28 Jun 2014, 05:59
Posts: 871
Location: San Francisco, CA USA
Has thanked: 147 times
Been thanked: 247 times
mooshiepieguy wrote:
I can hear something but it doesnt seem related to the disc playing just static. Any ideas on what I should do?


Open up the machine and look at the audio side of the circuit boards as a start. I’m not an expert but I assume if the machine plays with a decent pic that the transport and video side should be fine.

I would focus on looking for dry or leaky capacitors as well as cold solder like I mentioned before. Also, look for areas of the audio board that might look overheated (would be darker than other areas).
Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 6 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: