It is currently 18 Oct 2021, 13:57




 Page 1 of 1 [ 5 posts ] 
Author Message
 Post subject: CLD-939 won't play LDs
PostPosted: 17 Sep 2021, 03:08 
Knows how to post
Knows how to post
User avatar

Joined: 19 Nov 2017, 19:07
Posts: 13
Location: United States
Has thanked: 1 time
Been thanked: 0 time
Just got a CLD-939 (Japanese version of CLD-97) but it won't play any LDs. It spins for a couple seconds, then halts to a dreaded STOP. Same thing happens when I press play again.
CDs play, though.

According to the seller it was working before, so I'm thinking something got damaged during shipping. Any advice is greatly appreciated.


Last edited by thecatacomb on 18 Sep 2021, 08:11, edited 1 time in total.
Offline
 Profile  
 
 Post subject: Re: CLD-939 won't play LDs
PostPosted: 17 Sep 2021, 17:00 
Jedi Master
Jedi Master
User avatar

Joined: 03 May 2004, 19:05
Posts: 7413
Location: Dullaware
Has thanked: 824 times
Been thanked: 566 times
Are you certain the seller tested it with an actual LD and not just a CD???

Some sellers don't actually have any LDs and just test with what they have and say its working.
Offline
 Profile  
 
 Post subject: Re: CLD-939 won't play LDs
PostPosted: 17 Sep 2021, 21:22 
Knows how to post
Knows how to post
User avatar

Joined: 19 Nov 2017, 19:07
Posts: 13
Location: United States
Has thanked: 1 time
Been thanked: 0 time
That's another possibility. You live and you learn...

I wonder if opening it up and cleaning it could help?
Offline
 Profile  
 
 Post subject: Re: CLD-939 won't play LDs
PostPosted: 17 Sep 2021, 21:38 
Jedi Master
Jedi Master
User avatar

Joined: 03 May 2004, 19:05
Posts: 7413
Location: Dullaware
Has thanked: 824 times
Been thanked: 566 times
Check with the seller if they actually tested with LD, you may get a partial refund or return the player.

If its playing CDs then it should with LDs, unless the LD is slipping???
Could clean but make sure you don't mess up worse.
Offline
 Profile  
 
 Post subject: Re: CLD-939 won't play LDs
PostPosted: 18 Sep 2021, 01:02 
Advanced fan
Advanced fan
User avatar

Joined: 28 Jun 2014, 05:59
Posts: 917
Location: San Francisco, CA USA
Has thanked: 167 times
Been thanked: 273 times
Maybe you have a dirty spindle platter. Do you hear anything that sounds like slipping when trying to play LD? If so, that could cause the issue since the player needs to see 1800 rpm on the disc before it allows playback.

You can clean the rubber mat on the spindle w/ alcohol to see if that might fix it.
Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 5 posts ] 


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: