LaserDisc Database
https://forum.lddb.com/

CLD-V2400 tries to start for 10 seconds and then stops
https://forum.lddb.com/viewtopic.php?f=53&t=8053
Page 1 of 1

Author:  tikisteve [ 03 Oct 2018, 03:01 ]
Post subject:  CLD-V2400 tries to start for 10 seconds and then stops

I just got a CLD-V2400 that has a couple problems. The first problem is that when starting up a disc, the disc set light comes on correctly, but then when trying to play the disc, it spins up for about 10 seconds and then stops. The Play light flashes during this time.

The door also needs gentle help opening when ejecting a disc, but it seems to close OK. I don't know if these are related. The discs were slipping off the spindle until I cleaned the spindle face. Does anyone have any ideas? Thanks!

Author:  ldfan [ 03 Oct 2018, 05:00 ]
Post subject:  Re: CLD-V2400 tries to start for 10 seconds and then stops

Seems that I answer this question way too often. So let me try to give a general answer on LD player issues.


When players have oddball issues like not spinning up discs (but can identify them), have loading / unloading issues, doesn't go to Side B (on an auto reverse player), etc.; the issues are going to be a stretched loading belt about 80% to 90% of the time.

To test the theory that it is the belt, you can clean it with alcohol to remove possible contaminates (residual grease or just dirt) and see if the issue "improves". If it makes a slight difference, then one can assume the belt is the main culprit and ordering a new belt will fix the issue.


Other issues like the player having a whiny noise, taking forever to eject a disc (because the player is waiting for the disc to stop spinning), etc.; is usually indicative of a dirty disc clamper that can usually be cleaned w/ alcohol but in some cases may need the rubber mat on it replaced (or recoated).


So those are the first steps, IMHO, to take whenever one acquires a player that has a history of moderate use. ;) (If it's a player that has been used a lot and abused, could be all those things I mentioned and a whole lot more.)

Author:  rein-o [ 03 Oct 2018, 14:55 ]
Post subject:  Re: CLD-V2400 tries to start for 10 seconds and then stops

ldfan wrote:
Seems that I answer this question way too often. So let me try to give a general answer on LD player issues.



You only feel this now HAHAHAHAHAHAHAHAHA

This type of thing has been going on for the past 3 years.

How do I fix my slipping etc. :crazy: :crazy: :crazy: :cry: :cry: :cry:

Author:  ldfan [ 03 Oct 2018, 19:10 ]
Post subject:  Re: CLD-V2400 tries to start for 10 seconds and then stops

rein-o wrote:
You only feel this now HAHAHAHAHAHAHAHAHA

This type of thing has been going on for the past 3 years.




Well.... I was away for awhile and even back when I joined I wasn't really that active on the forum.

So I guess I must have missed a lot. ;)

Author:  rein-o [ 03 Oct 2018, 19:26 ]
Post subject:  Re: CLD-V2400 tries to start for 10 seconds and then stops

No matter, glad you are here.

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/