It is currently 18 Aug 2019, 00:08




 Page 1 of 1 [ 5 posts ] 
Author Message
 Post subject: [CLD-2850] Powers on but nothing moves - power supply ok  Topic is solved
PostPosted: 17 Mar 2019, 19:23 
Third post and above
Third post and above
User avatar

Joined: 25 Jan 2019, 20:10
Posts: 5
Location: Germany
Has thanked: 1 time
Been thanked: 0 time
Dear community,

I'm really new to LaserDisc electronics but maybe someone can help.

Symptoms:
The display lights up normally, but nothing moves - absolute silence (Laser doesn't move, spindle motor doesn't move).
If I press the open button the display tells me open (does nothing mechanically) and after some seconds changes to close (does nothing mechanically)
and again to the normal time code display.

What I have already done:
Didn't get the -12V rail, found "IC211" (fuse?) on the power supply was defective and replaced it, now all voltage test points have the correct value,
but symptoms still remain the same.
Also checked the mechanical part, everything seems fine here when I turn the gears manually.

I don't know where to start checking as it seems really complex for me, usually I only repair power supplies (capacitors) what mostly fixes the problems of electronics :lol:
It seems that the signal didn't get there to start anything as the voltages are correct arround the spindle motor/laser unit?

I appreciate your help and keep you informed. I also have the service manual, but as mentioned I need some help to spot the region where I should start searching :roll:

EDIT: There were some contact problems with the ribbon cables. - Problem solved.


Last edited by qwix on 25 Mar 2019, 16:07, edited 1 time in total.
Offline
 Profile  
 
 Post subject: Re: [CLD-2850] Powers on but nothing moves - power supply ok
PostPosted: 17 Mar 2019, 21:57 
True fan
True fan
User avatar

Joined: 15 Apr 2012, 10:36
Posts: 496
Location: Norway
Has thanked: 3 times
Been thanked: 4 times
Speaking of movement, what's the condition of the loading belt?
Offline
 Profile  
 
 Post subject: Re: [CLD-2850] Powers on but nothing moves - power supply ok
PostPosted: 18 Mar 2019, 00:49 
Third post and above
Third post and above
User avatar

Joined: 25 Jan 2019, 20:10
Posts: 5
Location: Germany
Has thanked: 1 time
Been thanked: 0 time
Thank you for your message.

The loading belt is fine. It seems to be an electronical issue.
I didn't get any voltages at the loading motor if I press open...

I digged deeper and tested some diodes and resistors but nothing suspicios. The plans in the service manual are crazy. Respect to all people knowing what's going on there :)
Offline
 Profile  
 
 Post subject: Re: [CLD-2850] Powers on but nothing moves - power supply ok
PostPosted: 18 Mar 2019, 09:24 
True fan
True fan
User avatar

Joined: 15 Apr 2012, 10:36
Posts: 496
Location: Norway
Has thanked: 3 times
Been thanked: 4 times
You might check this out. Diagnostic trouble codes to check for.
I think you should dissassemble it and check if the optical pickup is jammed and not able to move freely or not properly seated.
This video might give you some more insight. Good luck! :)
Offline
 Profile  
 
 Post subject: Re: [CLD-2850] Powers on but nothing moves - power supply ok
PostPosted: 18 Mar 2019, 11:03 
Third post and above
Third post and above
User avatar

Joined: 25 Jan 2019, 20:10
Posts: 5
Location: Germany
Has thanked: 1 time
Been thanked: 0 time
Thank you for your message.

In the video the guy has at the beginning exactly the same problem, but as I can move everything freely it seems that nothing is jammed. He also has a moving laser unit. For me nothing moves at all, I even lubricated the rails :cry:

I didn't get any error codes.

I think an electronical part is damaged as the fuse went bad.
Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 5 posts ] 


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: