It is currently 06 Jun 2020, 13:26




 Page 1 of 1 [ 4 posts ] 
Author Message
 Post subject: [CLD-D515] Disc tray will not open
PostPosted: 14 Mar 2020, 12:52 
Second post
Second post
User avatar

Joined: 13 Mar 2020, 22:13
Posts: 2
Location: United Kingdom
Has thanked: 1 time
Been thanked: 1 time
Hello!

I purchased an LD Player off ebay, I plugged it in and it powers on but upon pressing eject for either the cd tray or the ld tray, it seems like it's meeting resistance, as if some part is locked. It does not display an error code. I have a video of it in action here:

Any help would be greatly appreciated, thank you in advance!

Offline
 Profile  
 
 Post subject: Re: [CLD-D515] Disc tray will not open
PostPosted: 14 Mar 2020, 15:30 
Honest fan
Honest fan
User avatar

Joined: 27 Jul 2014, 20:59
Posts: 116
Location: United Kingdom
Has thanked: 22 times
Been thanked: 27 times
Maybe the belt has lost its torque? You see the wheel on the right hand side with the belt on it? Try turning that wheel by hand. If it opens you need a new belt. Had this issue on my 925. It would give me a u1 error sometimes as well. Not sure what else can go wrong with these.
Offline
 Profile  
 
 Post subject: Re: [CLD-D515] Disc tray will not open  Topic is solved
PostPosted: 14 Mar 2020, 16:29 
Honest fan
Honest fan
User avatar

Joined: 23 Aug 2019, 02:45
Posts: 81
Location: South Africa
Has thanked: 22 times
Been thanked: 14 times
Had a similar issue with my DVL-919, although only the LD part. The DVD tray had no problem ejecting. Replacing the belt fixed it all up.

Gently push the tray forward at the time it expects to be open. If there are no other issues, you should be able to get it to open.
Offline
 Profile  
 
 Post subject: Re: [CLD-D515] Disc tray will not open
PostPosted: 14 Mar 2020, 17:24 
Second post
Second post
User avatar

Joined: 13 Mar 2020, 22:13
Posts: 2
Location: United Kingdom
Has thanked: 1 time
Been thanked: 1 time
spyrogyro wrote:
Had a similar issue with my DVL-919, although only the LD part. The DVD tray had no problem ejecting. Replacing the belt fixed it all up.

Gently push the tray forward at the time it expects to be open. If there are no other issues, you should be able to get it to open.


This seems to have done the trick! Truth be told I was kind of scared of pushing it but it all seems to be working now. Thank you!
Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 4 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: