It is currently 26 Sep 2022, 19:51




 Page 1 of 1 [ 1 post ] 
Author Message
 Post subject: [MDP-800] Repair
PostPosted: 07 Aug 2022, 03:50 
Hardcore fan
Hardcore fan
User avatar

Joined: 13 Aug 2018, 03:18
Posts: 1509
Has thanked: 442 times
Been thanked: 571 times
I bought a broken MDP-800 yesterday. The seller said there was no audio. I opened it up and was greeted with the following:
Attachment:
MDP-800_1.jpg
MDP-800_1.jpg [ 92.84 KiB | Viewed 116 times ]

Attachment:
MDP-800_2.jpeg
MDP-800_2.jpeg [ 58.86 KiB | Viewed 116 times ]

Attachment:
MDP-800_3.jpeg
MDP-800_3.jpeg [ 55.13 KiB | Viewed 116 times ]

Attachment:
MDP-800_4.jpeg
MDP-800_4.jpeg [ 139.35 KiB | Viewed 116 times ]


The following caps were leaking:
Servo section: C299, C428, C430 47uF (I have seen these leak in a MDP-600 as well)
Audio section: C507 47uF
Power section: C707 100uF
Power supply: C31 C35 100uF

All of these capacitors were 35V.

After cleaning up all the leakage and replacing these, there was still no audio. +8VDC to audio section was somewhere around +2VDC. I replaced the +8V regulator in the power supply and was relieved to hear audio.

On to the adjustments now (once I find wherever my MDP adjustment cable is hiding). Unless the mechanical adjustments have drifted, it shouldn't take long since the only servo adjustments available are tilt balance for A and B.
Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 1 post ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: