It is currently 23 Jun 2024, 03:27




 Page 1 of 1 [ 4 posts ] 
Author Message
 Post subject: [DVL-909] Side A issues
PostPosted: 03 Nov 2022, 19:58 
Second post
Second post
User avatar

Joined: 20 Nov 2021, 01:46
Posts: 2
Location: United States
Has thanked: 0 time
Been thanked: 0 time
Wondering if anyone might be able to troubleshoot an issue on my long owned DVL-909… Recently when I try to play any laserdisc it’ll spin up for about a few seconds and then stop and coast down to a stop, never displaying anything other than than the play icon… Similar thing happens with dvds… However when I jump straight to the B side with the A->B button it spins up and plays fine… Belt issue? Lubrication issue?
Offline
 Profile  
 
 Post subject: Re: [DVL-909] Side A issues
PostPosted: 04 Nov 2022, 02:00 
Honest fan
Honest fan
User avatar

Joined: 01 May 2022, 00:30
Posts: 66
Location: United States
Has thanked: 34 times
Been thanked: 12 times
IMO, if you have never replaced the belt you should at least try that

I would also suggest replacing the grip ring BUT apparently the 909 uses the white grip ring just like the R7G which is not replaceable (or intended to be replaced), but perhaps a good cleaning would help (I don't know what to use to clean it but I'd bet someone else here would)

Edit: the 909 uses the VEB1184 belt, which is obtainable either through a generic SCQ3.8 belt (others recommend SCQ3.6, YMMV) or through laserparts
Offline
 Profile  
 
 Post subject: Re: [DVL-909] Side A issues
PostPosted: 05 Nov 2022, 05:42 
Hardcore fan
Hardcore fan
User avatar

Joined: 10 May 2007, 03:12
Posts: 1529
Location: United States
Has thanked: 0 time
Been thanked: 345 times
Not a belt issue. Could be side A centering or the tangential angle adjustment. I would try cleaning the lens first. If it still doesn’t play side A put in a CD and if it doesn’t play see if the spindle motor centering needs adjustment. If you have to adjust side A then you need to readjust side B. Tangential angle would be my last item to look at.
Offline
 Profile  
 
 Post subject: Re: [DVL-909] Side A issues
PostPosted: 09 Nov 2022, 02:25 
Second post
Second post
User avatar

Joined: 20 Nov 2021, 01:46
Posts: 2
Location: United States
Has thanked: 0 time
Been thanked: 0 time
Cleaning did nothing. CD plays just fine. Don’t have the equipment or confidence to go messing around with the tangential angle… But… I actually have gotten side A of an ld to play fine a half dozen or so times since posting this… but then the problem rearises.. then starts working again, and so on. When side A doesn’t play it seems almost as though it doesnt spin up to the necessary rpms. Might this actually be the symptom of a failing spindle motor? There were no gross problems with video/audio quality on side A before this sudden problem…
Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 4 posts ] 


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: