It is currently 06 Aug 2020, 19:38




 Page 2 of 2 [ 24 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: Sony SDP-E800 and display issue
PostPosted: 14 Dec 2015, 11:40 
Advanced fan
Advanced fan
User avatar

Joined: 22 Nov 2011, 18:54
Posts: 705
Location: United States
Has thanked: 0 time
Been thanked: 4 times
I tried to get digital sound from an analog source and it does not work. Apparently, the E800 can switch digital and analog sound; but, cannot do A/D conversion.

It certainly would be handy if it did.

I did find that it can switch video from the analog input to the monitor output. FWIIW
_________________
LD
Pioneer CLD-D406
Sony MDP-600
CED
934-54780150, 934.54810350, SJT-200, CED-1, 3-VIP1000, VIP201P
Offline
 Profile  
 
 Post subject: Re: Sony SDP-E800 and display issue
PostPosted: 21 May 2018, 05:46 
Advanced fan
Advanced fan
User avatar

Joined: 28 Jun 2014, 05:59
Posts: 583
Location: San Francisco, CA USA
Has thanked: 65 times
Been thanked: 124 times
It looks like my recently acquired SDP-E800 has a minor display issue as well. 8-)

In my situation, I get the following problem after it has been on for at least 30 to 45 minutes....

Image

The "i" disappears when on Digital 2 and 3 inputs as well as the "a" on the Analog input (no issues on the Digital 1 since that segment is blank due to the way the input information is displayed). Once the unit cools down again, the segment returns as normal.

Anyway, I figure it's probably a cold solder joint (had a similar issue with my Pioneer, CLD-3030 and soldering fixed the display) so I will be opening it up soon and soldering all the connectors in that region of the display. I think this happens a lot on this model since it does heat up (as everyone has mentioned) quite a bit. I'll report back later on how this repair goes and post pics as necessary.

Dave
Offline
 Profile  
 
 Post subject: Re: Sony SDP-E800 and display issue
PostPosted: 25 May 2018, 23:21 
True fan
True fan
User avatar

Joined: 21 Jun 2010, 20:03
Posts: 449
Location: TN, United States
Has thanked: 2 times
Been thanked: 3 times
Sounds great. I'd love to get mine fixed up someday.
Offline
 Profile  
 
 Post subject: Re: Sony SDP-E800 and display issue
PostPosted: 28 May 2018, 08:20 
Advanced fan
Advanced fan
User avatar

Joined: 28 Jun 2014, 05:59
Posts: 583
Location: San Francisco, CA USA
Has thanked: 65 times
Been thanked: 124 times
Ok...

As I mentioned in my previous post, here is the repair that I did on my SDP-E800's minor display issue (the missing "i" and "a" digit depending on the input selected). This repair will also fix any dimming issues as well (will have to solder more pins to the left and right of the one's I highlighted in the first picture).


After you remove the five screws holding the cover of unit in place, take a quick look @ the back of the display board and you will notice the row of pins I highlighted here....

Image

Although every pin is not going to have weak joints, it's still a good idea to resolder all of them since one can make the case that if one already got weak the others stand a chance of going bad later as well.

Now, in order to make this fix easy, it's better to remove the display board from the facade so you can lie it down on a table for a more convenient angle to solder.

So the next step is as follows.....

Image

Image

Image

Now with the board removed, you can see how the these pins connect to the display unit.

Image

Now it's time to solder and all you need to do is heat up each point and add a very tiny bit of solder (watch out and don't accidentally bridge one pin to another as you will damage the display when it gets powered back on; might want to ask someone with experience to help if need be).

Image

After getting all the pins soldered, it's a good idea to take a voltmeter, place it in "continuity mode" (it will beep on many voltmeters when the points are bridged by accident), and go down the entire row of pins w/ the probes touching the next adjacent pin. If these pins you test never set off a beep on the voltmeter, you're good to go with putting the unit back together.

Image

I ran my unit for over two hours after I was done and it's was perfect. No more disappearing digits. :thumbup:

Lastly... as a disclaimer, I don't hold any responsibility for damage to your unit if you try this on your own. It's still a risk if you don't have any experience w/ soldering irons and voltmeters so I do emphasize getting a friend to help who has some basic electronics knowledge.
Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 2 of 2 [ 24 posts ]  Go to page Previous  1, 2


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron