It is currently 22 Oct 2019, 04:18




 Page 1 of 1 [ 9 posts ] 
Author Message
 Post subject: [HLD-X9] Power issue
PostPosted: 08 Mar 2018, 02:04 
Knows how to post
Knows how to post
User avatar

Joined: 19 Oct 2016, 18:08
Posts: 8
Location: United States
Has thanked: 2 times
Been thanked: 1 time
I recently picked up an HLD-X9 that potentially has some sort of power issue. After plugging it in to a 100v step down transformer and pressing the soft power, the display will light up, flash a few times and then go out. None of the internal motors move (loading motor or laser transport), the unit is completely silent.

My admittedly untrained eye can't find anything obviously wrong internally. The tray was salvaged from a D503 with the 3" disc surface removed, so that's fully intact. All the fuses pass continuity, plus no obviously bulging/leaking capacitors or unplugged cables that I can find. The loading belt is brand new (but the motor isn't moving anyway).

Was wondering if this sounds like a familiar or common fault to anyone? Thanks in advance!
Offline
 Profile  
 
 Post subject: Re: [HLD-X9] Power issue
PostPosted: 08 Mar 2018, 03:55 
Confirmed Padawan
Confirmed Padawan
User avatar

Joined: 14 Jan 2010, 09:44
Posts: 3778
Location: United States
Has thanked: 87 times
Been thanked: 215 times
I’d suspect the step down. Is it legit or some airport POS? (Ie: does it have a metal chassis?) Until you can fully load test your mains you’re just guessing. Plug a blender into it or something.
Offline
 Profile  
 
 Post subject: Re: [HLD-X9] Power issue
PostPosted: 08 Mar 2018, 04:29 
Knows how to post
Knows how to post
User avatar

Joined: 19 Oct 2016, 18:08
Posts: 8
Location: United States
Has thanked: 2 times
Been thanked: 1 time
Unfortunately it's been tried on more than one step down, high quality beefy metal ones from Japan. I wish it was that simple. :)
Offline
 Profile  
 
 Post subject: Re: [HLD-X9] Power issue
PostPosted: 08 Mar 2018, 04:44 
Confirmed Padawan
Confirmed Padawan
User avatar

Joined: 14 Jan 2010, 09:44
Posts: 3778
Location: United States
Has thanked: 87 times
Been thanked: 215 times
Oh well, that’s the extent of my knowledge on this issue! :)
Offline
 Profile  
 
 Post subject: Re: [HLD-X9] Power issue
PostPosted: 08 Mar 2018, 05:00 
Knows how to post
Knows how to post
User avatar

Joined: 19 Oct 2016, 18:08
Posts: 8
Location: United States
Has thanked: 2 times
Been thanked: 1 time
Hey, no worries- checking your power input in definitely good advice. This weekend I'll see if I can measure some voltages around the chassis and see if anything seems off there. There are a couple of extremely scary capacitors on the right hand side of the unit that hold a massive charge even after the unit's been unplugged so I'm a little nervous about brushing against those accidentally. They have "discharge" points on the backside of the board, and boy do they ever discharge.
Offline
 Profile  
 
 Post subject: Re: [HLD-X9] Power issue
PostPosted: 08 Mar 2018, 05:14 
Jedi Master
Jedi Master
User avatar

Joined: 03 May 2004, 19:05
Posts: 5883
Location: United States
Has thanked: 106 times
Been thanked: 142 times
Yeah, your best bet is to try your hand at using a multi meter and make sure you are getting the correct voltage, I would even check to make sure the
fuses are correct.
But that's even the extent of my knowledge, and you are doing whatever at your own risk.

You didn't get the one on ebay that was listed as a project did you???
Offline
 Profile  
 
 Post subject: Re: [HLD-X9] Power issue
PostPosted: 08 Mar 2018, 05:20 
Knows how to post
Knows how to post
User avatar

Joined: 19 Oct 2016, 18:08
Posts: 8
Location: United States
Has thanked: 2 times
Been thanked: 1 time
This one's from Yahoo auctions via Jauce (first time using them), but it wasn't listed as tested/working either. Definitely a gamble.
Offline
 Profile  
 
 Post subject: Re: [HLD-X9] Power issue
PostPosted: 26 Mar 2018, 22:43 
Knows how to post
Knows how to post
User avatar

Joined: 19 Oct 2016, 18:08
Posts: 8
Location: United States
Has thanked: 2 times
Been thanked: 1 time
Picked up another HLD-X9 "junk" item from Yahoo; this one was easy to get going. New loading belt & clamp slip ring and it was good to go. I'll keep the other X9 for parts just in case.
Offline
 Profile  
 
 Post subject: Re: [HLD-X9] Power issue
PostPosted: 27 Mar 2018, 01:02 
Confirmed Padawan
Confirmed Padawan
User avatar

Joined: 14 Jan 2010, 09:44
Posts: 3778
Location: United States
Has thanked: 87 times
Been thanked: 215 times
I’d keep the old one around for sure. Power issues are, relatively speaking, easy fixes. Even if you have to build a new power supply for it...hey, it’s easier than building a laser or a spindle motor.
Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 9 posts ] 


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: